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HYPACK 2022 Q2 Release Notes
By Caroline Liu

HYPACK INTERFACE (SHELL)
NEW FEATURES
•

Users can now reposition targets in the HYPACK® Map window by clicking and
dragging them. While the Add Target tool is selected, mousing over an existing target
will draw a red circle inside or around the target, depending on scale of the map.
To move a target:
1. From the Map View tools on the right of the Map window, click the

Add Target icon.
2. Mouse over the target of interest and make sure that the red circle appears.
3. Left click the target and drag to the desired position. A red line will connect the current
position of the target to the position of the mouse while the left mouse button is held
down.
4. Release the left mouse button to drop the target in its new position.
Note that the process for adding new targets remains the same as long as an existing
target is not highlighted with the red circle.

•

Data within the boundaries of a matrix are now kept by default when users resize
and save a matrix file in the Matrix Editor. Previously in the Matrix Editor, Save as and
Save would either create or overwrite an existing matrix with a new empty matrix. Now,
users can adjust the matrix boundary, cell size, and rotation, then select File -> Save or
Save As to remap data from the original matrix to the current matrix settings. Save will
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save the updated matrix settings to the currently selected matrix, and Save As saves the
current matrix to a new file.
In the following example, Hal.mtx (top image) is the original matrix. The matrix (light
green border) is resized and rotated, then File -> Save As was selected to create a new
matrix named Hal_NewMtx.mtx, while also saving data from Hal.mtx that are within the
boundary of the new matrix (bottom image).
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•

Added the Save Empty Matrix option to the Matrix Editor because Save As and Save
no longer create or overwrite an existing file with an empty matrix.

To create a new empty matrix, go to File -> Save Empty Matrix, type in the new matrix file
name, then click [Save]. If the user saves the new matrix in the current project, the matrix
name appears in the Project Items list under Matrix Files.

•

•

To overwrite an existing matrix file with an empty matrix, go to File -> Save Empty Matrix,
then select the name of the file to overwrite and click [Save].
Users can now display Depth/Elevation, Date/Time, or Text for bucket (*.bkt) files in
the Shell. To do this, from the Project Items list, navigate to Project Files and right click
the Bucket Files folder. From the menu, navigate to Display Label and select from the
options None, Depth/Elevation, Date/Time, and Text. These will only work if Draw Style
“Hollow” or “Solid” is selected. The date will only display if the bucket file has the date file
naming convention M(M)_D(D)_YYYY.bkt or MMDDYYYY.bkt.
Users can connect parallel offset lines in a “Z” pattern for autonomous vehicles,
where the end of one line connects back to the beginning point of the next line. To
do this, from the Line Editor click Offsets, then in the Parallel tab, set your line parameters
and click “Connect Lines (For Autonomous Vehicles).”
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SOUNDING COLORS
•

Select Color Table - In the Select Color Table dialog, right clicking on the Project or
Shared folders and selecting Add Group allows you to add other user-defined
folders that contain color files (*.hcf). Once you’ve selected your folder from the file
explorer and clicked [OK], that folder and all color files contained within are added to the
bottom of the Select Color Table tree view. This allows color files residing in any folder to
be used in the Project.

These user-added folders can be removed by right clicking the name of the folder and
selecting Delete Group. Note that you will be unable to delete the Project or the Shared
folders.
Access the Select Color Table dialog from the Shell by clicking the Sounding Colors tab > [Select Color Table] button.
•

Color Table Editor - Removed the Open (Shared), Save (Shared), and Save As
(Shared) menu items. Open and Save As now open a dialog where you can set the
file name and select the folder (Project or Shared folder) the file is in or will be saved to.
You can also select either the Project or Shared folder and click Browse to open that
folder. Any additional folders added by the user in the Color Select Dialog will also be
included in the Folder drop down (bottom image).
Access the Color Table Editor from the Shell by clicking the Sounding Colors tab -> [Edit
Color Table] button.

4

Save will simply update the file on the disk if it is already associated with a file name, or
will behave like Save As was clicked if no file name association exists yet.
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PREPARATION
HYSWEEP HARDWARE
•

In the Q1 update, we added the Teledyne Reson SeaBat T51 driver. At the time, users
needed to manually select the sonar frequency in HYPACK® Hardware setup while the
survey was not running. Now, sonar frequency automatically switches between 400
and 800 kHz without needing to stop and restart HYSWEEP® survey. We also
support this frequency change in successive pings. Since frequency switching is now
automatic, we’ve removed the frequency selection from the Reson Setup window.

TARGET EDITOR
•
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Users can now import target text (*.txt) or target (*.tgt) files from the Target Editor
using the new Import tab. To use this new function, from the Shell go to Preparation ->
Editors -> Target Editors, then click the Import tab.

Click [Open File], then select the *.txt or *.tgt file with the data you want to import. Once
the file has been selected, the lower half of the Import tab populates with the details of
each target within the file.
Next, from the upper left of the Import dialog, check each variable that is included in your
file. You can click and drag items in the list to reorder them to reflect the order of data in
your file. If there is extra information that does not match a variable or information you do
not want to include, click [Add Ignore Field], then check and drag the Ignore label so that
the list is ordered correctly.

Select the delimiter your file used (comma, space, or tab), and coordinate units (Local or
WGS84) from the drop down menus. Check the Skip Problem Lines box, then click
[Check Syntax] to verify if the information you’ve provided in the Import tab matches what
is in your target file. The message box will inform you how many lines are inaccurate.
Once you’ve corrected any issues, click [Convert], and your targets will be imported to the
Target Editor.

NEW! REMOTE VIEWER
HYPACK Survey Viewer has now been replaced by HYPACK Survey Remote Viewer.
With this updated program, users can view and control a hosted HYPACK Survey
screen from remote desktop computers and mobile devices. Viewing devices no longer
need to have the HYPACK Survey Viewer program installed. Instead, these secondary
devices now connect to the host computer from the same network. This means any mobile
device that can connect to the internet with the appropriate browser/support capabilities can
be used to view and control the hosted HYPACK Survey screen.
For more details on how to configure and use the new Remote Viewer, check out our
Remote Viewer guide.
The general setup process is:
1. Open Remote Viewer and set up remote access on the hosted HYPACK Survey screen
by clicking Options -> Remote View Over Web. You will need to enable remote access
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and configure the internal port number, remote credentials, and performance settings in
the Remote Access window.

2. Verify that the Remote Viewer has initiated correctly by loading it on the computer hosting
Survey. In a web browser, type the IP address with port number, and log into the Remote
Viewer authenticator with the credentials you set up in step 1.
3. Once you’ve confirmed that Remote Viewer is functioning as intended, log into Remote
Viewer from a different computer or mobile device. First find the IP address of the host
computer. In a web browser on a different computer, type in the IP address and port
number, and log into the Remote Viewer authenticator with the credentials you set up in
step 1.
Note that in order to view HYPACK Survey with the Remote Viewer, the host computer
must be connected to the same network as the other devices.
While the interface has been completely overhauled, Remote Viewer retains the
original controls that were in the HYPACK Survey Viewer. We’ve also added the data
toggle button on the right side of the data display, which allows users to show or hide the
data display and left/right indicators:
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HYPACK Survey Remote Viewer also features a newly designed mobile interface:
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DATA ACQUISITION
SURVEY
•

We’ve added Boat Speed (fps and knots), Ping Rate (Hz), and Average Ping Time
(sec) to the Device Health window. Users may find these values helpful for maintaining
an acceptable boat speed to maintain along track data density. To view the Device Health
window, from the Survey window click Options -> Shared Memory -> Device Health.

DREDGEPACK
DRIVER UPDATES
•
•
•
•
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Excavator.dll: Telestra MCAS devices using PEAK or Ixaat CAN bus connectors are now
supported and connect automatically.
HD25A.dll: Changes were made to update interface and stabilize driver performance.
Inclinometer.dll: Added support for Telestra MCAS devices and Allen Bradley PLC.
Added TelestraPR.dll: This is new a pitch/roll only driver for the Telestra MCAS devices.
Previously you had to use a second instance of Excavator.dll to obtain pitch/roll.

SIDE SCAN SURVEY
KLEIN MA-X VIEW 600 SUPPORT
HYPACK now supports the Klein MA-X View 600 Side Scan sonar, which is Klein’s
revolutionary new nadir gap-filling sonar. The MA-X View 600 provides vastly improved
nadir coverage by augmenting its side scan sonar with a forward-looking center channel
sonar. This new integration includes the following features:
•
•
•
•
•
•
•

A new driver named ALSLib20_32.dll, which must be included for the MA-X View 600
to work. This driver is included in the HYPACK 2022 Q2 release files.
Users will add and set up the Klein MA-X View 600 from HYPACK Combined Hardware
under Side Scan Devices.
The center channel data is viewable in HYPACK Survey in the Side Scan Waterfall 2
window.
Users can choose to display the entire range of the center channel or view only the
default range.
QC Display shows the fish’s altitude, pitch and center channel’s “lookahead” direction.
Targeting in center channel is fully supported.
MA-X View data can be post-processed in HYPACK using normal workflows.

For additional details on how to use the Klein MA-X View 600, check out:
•
•

•

Our article on getting started with the Klein MA-X View 600
HYPACK’s integration announcement:
https://www.hypack.com/about-hypack/blog/hypack-news-blog/2022/06/ma-x-view-600in-hypack
Specifications for Klein MA-X View 600:
https://mind-technology.com/klein/klein-ma-x-view-600/

KLEIN MA-X VIEW 600 - LOOKAHEAD CHANNEL DATA
The MA-X VIEW 600 has a center channel that “looks ahead” of the sonar. HYPACK®
logs this information to the HSX file as an LAH record.
Lookahead data is tagged as LAH, and data format is:
LAH dn t a d
where:
dn: device number
t: time tag (seconds past midnight)
a: depression angle of lookahead sonar (in decimal degrees, positive down)
d: lookahead distance to bottom (in meters)

ADDITIONAL SIDE SCAN SURVEY UPDATES
•

The Side Scan signal graph now automatically updates when switching between
gain types to give users better signal visualization and better initial colors.
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•

AGC (Automatic Gain Control) has been added to TVG options. In Side Scan Survey,
go to View -> Options -> Gain and select AGC from the dropdown. Adjust sliders in the
main Sidescan Survey window to get a good image. Note that in the main Sidescan
Survey window, Toggle TVG Mode icon will read “Auto2” when AGC is selected.

HYSWEEP® SURVEY
•

HYSWEEP® has been updated to support NORBIT yaw stabilized multibeam sonars
(WINGHEAD i80s and i87s). HYSWEEP® now processes data in a way that shows
accurate real time displays matrix fills.

SURVEY LOG
•

•
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Added functionality to load survey log data with header info from the previous
session. When the Survey Log program is launched, users are prompted to choose if
they want to load the survey log data from the previous session (“Do you want to load
previous session data?”). Select [Yes].
Changed exit question to “Would you like to export survey log before exiting?” When
exporting the survey log, the default file extension is *.PDF.

POST-PROCESSING
64-BIT SINGLE BEAM EDITOR (SBMAX64)
•

RTK tide values are now calculated from S7K files and applied to the corrected depth in
the Spreadsheet window. To do this, from the Single Beam Editor the user needs to open
Show Read Parameters -> Advanced tab, then check the RTK Tide Method checkbox.

64-BIT HYSWEEP® EDITOR (MBMAX64)
•

Added the Go To Position function, which allows users to move their cursor to a
sounding by entering an X/Y position or Latitude and Longitude coordinates.
To use this function:
1. Open MBMAX64, load and perform Stage 1 editing on your data, then advance to
Stage 2 processing by clicking File -> Stage 2 (Depth Editing).
2. From the top toolbar, click View -> Go To Position to open the Go To Position display.
The display initiates with the current coordinates of the cursor in the list box on the right.
X/Y are shown in feet or meters depending on the working units, and Latitude and
Longitude are show in decimal degrees.
In the example below, the initial cursor position and X Y coordinates are boxed in blue.

3. Enter new values for X and Y (or Longitude and Latitude), then click [Add]. The cursor
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will move to the sounding at or closest to the newly entered location, and add the new
coordinates to the list box.

Note that [Up] and [Down] are enabled after a new set of coordinates are added to the list of
positions with [Add]. Clicking [Up] or [Down] will move the cursor to the previous or next
location in the list, respectively. If multiple locations have been added, [Up] and [Down]
function similarly to the "Undo" and “Redo” features and cycle to previous or subsequently
added positions. Once the cursor has reached the first position, [Up] will be disabled.
The list of coordinates will also include Target locations and descriptions if the
Targets check box is selected in the top menu under Show. Targets will not be displayed
if Targets is unchecked.
In the example below, three targets (white dots) are displayed on the MBMAX64 map and
shown in the Go To Position coordinates list (blue box).
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SIDE SCAN TARGETING AND MOSAICKING
•

In Phase 3 of Targeting and Mosaicking, you can now select which frequency you
want to mosaic from the Frequency drop down box. To use this new feature, from the
Shell click Side Scan -> Targeting and Mosaicking, then from the Side Scan Mosaic
window click Mode -> Mosaic. In the Mosaic window make sure you are in the General
tab, then select from the Frequency drop down.
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FINAL PRODUCTS
HYPLOT MAX
•
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When a title block is frozen, the title block container as well as its text boxes can no
longer be moved or resized, even if the text boxes do not have a lock icon next to
them in the tree view.
Remember you can add title blocks in HYPLOT MAX by clicking Add -> Block, then
selecting a block file (*.htb) from the list. The title block and all nested text boxes will
appear on the plotting sheet and the Items tree view on the left. To lock the title block,
right click on its name in the tree view, then click Frozen. A lock icon will appear next to
the name of the title block.

UTILITIES
ADCP PROFILE
•

Users can now auto scale colors from the main ADCP Profile window instead of
from the Options menu. The ADCP Profile toolbar now has an auto scale drop down,
which allows users to set the color scale to No Scaling, Scale All Files, or Scale Current
File. Additionally, the Auto-Scale Colors checkbox is removed from the Profile View tab in
the Options window.

•

We’ve added an Intensity value display to the Information window. In addition to
other ADCP Profile data (ie: Bin data, heading, pitch, roll, etc), this window now
shows intensities in different locations of the ADCP Profile.
To open the Information window, from ADCP Profile click View -> Information (or use
CTRL + I). Make sure the Profile tab is selected in the ADCP Profile window. The data in
the Information window, which includes the new display of Intensity values, will update as
you move your cursor around the profile.
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•
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Users now have the option to save Beam Intensity values to XYZ Intensity (XYZI)
files. To do this, in the ADCP Profile window click File -> Beam Intensity to XYZI. Save
Current Line exports the beam intensities of the currently selected file to an XYZI file, and
Save All Lines exports beam intensities of all loaded files to multiple XYZI files. The XYZI
files can be loaded into Cloud to visualize the signal to noise along the track.

